Завершен

Выгрузка номенклатуры на ТС

Расим 4 года назад в Проблемы с 1С обновлен Сергей (Специалист) 4 года назад 3

При выгрузке номенклатуры на ТСД выгружается только одна позиция, в чем может быть проблема?

Выгрузка проходит без ошибок.В каталоге \Documents появляется файлик "ProductsBook" только с одной позицией

Выгрузка самописная(по документации)


ПрогИД = "AddIn.Cl.TerminalConnector";

ПодключитьВнешнююКомпоненту(ПрогИД);
мДрайверТСД = Новый (ПрогИД);
мТипПодключенногоДрайвера = мДрайверТСД.GetDriverType();
ДрайверТСД = мДрайверТСД;
МассивПодключения = Новый Массив;
МассивПодключения.Добавить(1);
МассивПодключения.Добавить(СтрокаПодключения);
Если Не мДрайверТСД.ПроверитьСоединениеССервером(МассивПодключения) Тогда
Ошибка= "";
мДрайверТСД.ПолучитьОшибку(Ошибка);
ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Не удалось подключиться к базе данных MS: "+Ошибка);
Возврат;
КонецЕсли;
мДрайверТСД.УстановитьПоискПоНаименованиюИАртикулу(Истина);
Если Не мДрайверТСД.НачатьВыгрузкуТоваров(мДанныеВыгрузки) Тогда
Ошибка = "";
мДрайверТСД.ПолучитьОшибку(Ошибка);
ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Ошибка при инициализации выгрузки: " + Ошибка);
мДрайверТСД.ОсвободитьРесурсы();
Возврат;
КонецЕсли;
мсвСтрок = ПолучитьСтрокиВыгрузки();
Для Каждого Строка Из мсвСтрок Цикл
Если Не мДрайверТСД.ДобавитьВВыгрузкуТоваров(Строка) Тогда
Ошибка = "";
мДрайверТСД.ПолучитьОшибку(Ошибка);
ОбщегоНазначенияКлиентСервер.СообщитьПользователю( "Ошибка при выгрузке данных: " + ". " + Ошибка);
Прервано = Истина;
Возврат;
КонецЕсли;
КонецЦикла;
Если Не мДрайверТСД.ЗавершитьВыгрузкуТоваров() Тогда
Ошибка = "";
мДрайверТСД.ПолучитьОшибку(Ошибка);
ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Ошибка при завершении выгрузки: " + Ошибка);
Возврат;
КонецЕсли;

Установленный продукт:
Mobile SMARTS ЕГАИС
Версия драйвера:
2.7.1.10
Типовая конфигурация драйвера?:
Да
Операционная система:
Windows 2003
Версия и конфигурация 1С, и режим работы (Файловы или Серверный):
Retail Suite. Система автоматизации розничных предприятий (7.0.3.2) Файловыq
Типовая конфигурация 1с?:
Нет
Модель ТСД:
Motorola mc65

Mobile SMARTS ЕГАИС работает на платформе Mobile SMARTS версии 3.0, почему у Вас версия драйвера 2.7.1.10? Вместо ПроверитьСоединениеССервером используйте мДрайверТСД.Подключить(МассивПодключения, ""). В массиве должен быть один элемент - строка подключения к базе Mobile SMARTS (для платформы версии 3). Что содержится в массивах, которые передаются в НачатьВыгрузкуТоваров и в ДобавитьВВыгрузкуТоваров? После вызова ДобавитьВВыгрузкуТоваров не переходит по ошибке?

Проблема решилась пререгистрацией библиотек,номенклатура перегружается на терминал сейчас версия драйвера 3.

Сервис поддержки клиентов работает на платформе UserEcho