Завершен

по справке а

Абдулхалик 4 года назад в Проблемы с 1С обновлен Алексей (Старший специалист) 4 года назад 4

Добрый день.

Как организовать выгрузку из Утап справок А

Установленный продукт:
MS егаис
Версия драйвера:
3.0.0.2667
Типовая конфигурация драйвера?:
Да
Операционная система:
win
Версия и конфигурация 1С, и режим работы (Файловы или Серверный):
Утап (11.1.10.204
Типовая конфигурация 1с?:
Нет
Модель ТСД:
DSS5

Если ЭлементыФормы.ВыгружатьСправки.Значение Тогда

ЗапросСправок2 = Справочники.алкКлассификаторСправокАиБ.Выбрать();
Обработка = Неопределено;
Объект = Неопределено;
Результат = ПолучитьОбъектДрайвера(ТерминалСбораДанных, Обработка, Объект);
мЕнв = Объект.Драйвер;
Пока ЗапросСправок2.Следующий() Цикл
Для Каждого СтрокаСправок из ЗапросСправок2.ДиапазоныНомеров Цикл
мДанные = Новый Массив(4);
мДанные.Установить(0, "КодФормы" );
мДанные.Установить(1, "Начало");
мДанные.Установить(2, "Конец");
мДанные.Установить(3, "АлкоКод");;
Если Не мЕнв.НачатьВыгрузкуТаблицы("ФормыА", мДанные, Истина) Тогда
ОписаниеОшибки = "";
мЕнв.ПолучитьОшибку(ОписаниеОшибки);
Сообщить("Ошибка при выгрузке таблицы: " + ОписаниеОшибки);
мЕнв.ОсвободитьРесурсы();
КонецЕсли;
мДанные.Установить(0, Строка(ЗапросСправок2.Ссылка) );
мДанные.Установить(1, Формат(Число(Формат(СтрокаСправок.НачальныйНомер, "ЧРГ=; ЧГ=")),"ЧЦ=; ЧДЦ=; ЧС=; ЧРД=; ЧРГ=; ЧН=; ЧВН=; ЧГ=; ЧО="));
мДанные.Установить(2, Формат(СтрокаСправок.КонечныйНомер,"ЧРД=; ЧГ="));
мДанные.Установить(3, ЗапросСправок2.Ссылка.Владелец.Код);
Если Не мЕнв.ДобавитьВВыгрузкуТаблицы(мДанные) Тогда
ОписаниеОшибки = "";
мЕнв.ПолучитьОшибку(ОписаниеОшибки);
Сообщить("Ошибка при выгрузке таблицы: " + ОписаниеОшибки);
мЕнв.ОсвободитьРесурсы();
КонецЕсли;
Если Не мЕнв.ЗавершитьВыгрузкуТаблицы() Тогда
ОписаниеОшибки = "";
мЕнв.ПолучитьОшибку(ОписаниеОшибки);
Сообщить("Ошибка при выгрузке таблицы: " + ОписаниеОшибки);
мЕнв.ОсвободитьРесурсы();
КонецЕсли;
КонецЦикла;
КонецЦикла;

// --- алко

Добрый день в какую процедуру нужно вставить код

Можно в процедуру выгрузить, например, в форму выгрузки номенклатуры.

Загрузка документов.epf Выгрузка документов.epf

Во вложении обработки загрузки и выгрузки документов ЕГАИС. Релиз на сайт выложим только на следующей неделе.

Сервис поддержки клиентов работает на платформе UserEcho