Завершен

Выгрузка дополнительных таблиц

Чухно Евгений 3 года назад в Прочие разделы / - Вопросы по разработке обновлен Илларион (Специалист) 3 года назад 3

Добрый день! Данный вопрос неоднократно задавался, были получены ответы. Но периодически(с обновлениями) данные методы выгрузки переставали работать, а мануалов опубликованных нет.

Каким методом сейчас можно выгрузить дополнительную таблицу?

Вами были озвучены методы


1-

Таблица = Новый COMОбъект("Cleverence.Warehouse.DocumentTable");
Таблица .Name = "Имя";
СтрокаТаблицы = Новый COMОбъект("Cleverence.Warehouse.Row");
СтрокаТаблицы.SetField("SomeVar", Значение);
ТаблицаСерий.Rows.Add(СтрокаТаблицы);
мОбъектТСД.Драйвер.ВыгрузитьДопТаблицу(Таблица );
мОбъектТСД.Драйвер.ОсвободитьРесурсы();


2-

КомДляMS = Новый COMОбъект("AddIn.Cl.TerminalConnector");
СписБаз = Новый Массив;
СтрокаПодключенияКСерверу = "ip";
СписБаз.Добавить(СтрокаПодключенияКСерверу);
КомДляMS.Подключить(СписБаз,""); // подключение к базе
мДанные = Новый Массив(1);
мДанные[0] = "SomeVar";
Если НЕ КомДляMS.НачатьВыгрузкуТаблицы("Таблица", мДанные, Истина) Тогда // Начинаем выгрузку, установив массив полей
 Сообщить("Ошибка при начале выгрузки");
 Возврат;
КонецЕсли;

мДанные[0] = Значение;

Ответ = КомДляMS.ДобавитьВВыгрузкуТаблицы(мДанные); //Добавляем порцию данных в выгрузку
Если НЕ Ответ Тогда
 Возврат;
КонецЕсли;
КонецЦикла;
Ответ = КомДляMS.ЗавершитьВыгрузкуТаблицы(); //Завершаем выгрузку


------

Какой из методов должен работать в последней версии? В данный момент перестали работать оба.

Установленный продукт:
WiFi PROF
Версия драйвера:
3.0.0.45455
Типовая конфигурация драйвера?:
Нет
Операционная система:
Windows 10
Версия и конфигурация 1С, и режим работы (Файловы или Серверный):
УТАП 11.2 Серверный.
Типовая конфигурация 1с?:
Нет
Модель ТСД:
MobileBase DS5
ХОРОШО, МНЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от Чухно Евгений 3 года назад

Добрый день!

Должны работать оба варианта. В чем именно у Вас ошибка?

Справка по объекту TerminalConnector v.3 здесь: http://www.cleverence.ru/devlib/TerminalConnector_v3/index.html

См. также http://www.cleverence.ru/files/14505/Mobile%20SMARTS%203.0.%20%D0%A0%D0%B0%D0%B1%D0%BE%D1%82%D0%B0%20%D1%81%20%D0%BA%D0%BE%D0%BC%D0%BF%D0%BE%D0%BD%D0%B5%D0%BD%D1%82%D0%BE%D0%B9.pdf

Лучше выполнять выгрузку с помощью функций НачатьВыгрузкуТаблицыДобавитьВВыгрузкуТаблицыЗавершитьВыгрузкуТаблицы


Спасибо! Способ №2 заработал как только я стал подключаться не по ip:port сервера(раньше работало), а по ид подключения.

Сервис поддержки клиентов работает на платформе UserEcho