На рассмотрении

Внешняя обработка

Николай Дементьев 3 года назад в Магазин 15 / - Раздел по 1С обновлен 3 года назад 5

При открытии обработки обычным пользователем (который будет с ней непосредственно работать) вываливается ошибка доступа.

Право: АдминистрированиеДанных

Обработка: (8.3) Магазин 15 - Управляемые формы.epf


С обработкой только с полными правами получится работать?

Установленный продукт:
Магазин 15, Базовый
Версия драйвера:
Версия обработки 1.0.1.110
Типовая конфигурация драйвера?:
Да
Операционная система:
Windows 10
Версия и конфигурация 1С, и режим работы (Файловы или Серверный):
УТ 11.1, серверный
Типовая конфигурация 1с?:
Да
Модель ТСД:
на Android
На рассмотрении

Добрый день,

Какие права требуется для обработки:
- Запуск внешних обработок
- Доступ к запрашиваемым справочникам
- Доступ к регистрам сведений 
- Доступ к регистрам накоплений 
- Другие ограничивающие права возможности обработки (Например: Для выгрузки документов потребуются все соответствующие права, на получение списка типов документов, списка документов по типу документа и на доступ к самому документу)

Ругается на этот кусок кода.

Т.е. попытка получить настройки пользователя "", а получить настройки другого пользователя можно только под с правом "АдминистрированиеДанных" (у обычных пользователей этого права нет).


&НаСервереБезКонтекста
Функция ПолучитьПараметрыТСД() Экспорт

Перем ПараметрыИзХранилища;

ПараметрыИзХранилища = ХранилищеОбщихНастроек.Загрузить("CleverenceПараметрыТСД", , "","");
Если ПараметрыИзХранилища = Неопределено Тогда
ПараметрыИзХранилища = Новый Структура;
КонецЕсли; 

Возврат ПараметрыИзХранилища;

КонецФункции

Тоже самое при сохранении настроек:


&НаСервереБезКонтекста
Процедура СохранитьПараметры(ПараметрыТСД, КлючОбъекта = Неопределено) Экспорт

Если КлючОбъекта = Неопределено тогда
КлючОбъекта = "CleverenceПараметрыТСД";
КонецЕсли;

ХранилищеОбщихНастроек.Сохранить(КлючОбъекта, "", ПараметрыТСД, "");

КонецПроцедуры

Добрый день!

Во вложении последняя обработка, у вас обработка запускается на том же ПК, где и расположен сервер 1с или на клиенте? 

(8.3) Магазин 15 - Управляемые формы.epf


Сервер Mobile SMARTS запущен?

Пришлите логи из папки \Programdata\cleverence\Logs


Эта ошибка появилась или всегда была? 

Обработка запускается на клиенте, там же где и база Mobile SMARTS развернута.

С последней обработкой тоже самое.

Сервер Mobile SMARTS запущен? Да :).

Логи Logs.zip .


Я поправил в обработки эти строки, все заработало как надо, только для каждого пользователя 1С приходится отдельно настройки сохранять.

ПараметрыИзХранилища = ХранилищеОбщихНастроек.Загрузить("CleverenceПараметрыТСД", , "");

и

ХранилищеОбщихНастроек.Сохранить(КлючОбъекта, "", ПараметрыТСД);

Сервис поддержки клиентов работает на платформе UserEcho