Завершен

Текущая база Mobile SMARTS не установлена

Евгений Мишин 3 года назад в Драйвера 1С обновлен Илларион (Специалист) 3 года назад 3

Делаю перевод на новую платформу 3. После всех процедур. Конфигурация у нас переписаная, есть серверные таблицы. Пытаюсь их заполнить из 1С.

    Ошибка = "";

    ПодключитьТерминал();
    
    Если мОбъектТСД = Неопределено Тогда
        Возврат;
    КонецЕсли;

    Если мStorageConnector = Неопределено Тогда
        Попытка
            мStorageConnector = мДрайверТСД.CreateStorageConnector();
        Исключение
            Сообщить("Ошибка при подключении сервера Mobile SMARTS: " + ОписаниеОшибки());
            Возврат;
        КонецПопытки;        
    КонецЕсли;
    СтрокаТаблицы = Новый COMObject("Cleverence.Warehouse.Row");
    tableName = "ТранзитныеСклады";
    
    Для каждого ТекСтрока из Объект.Склады Цикл
        ТекСклад = ТекСтрока.Склад;
        Если не ЗначениеЗаполнено(ТекСклад) Тогда
            Продолжить;
        КонецЕсли;
        ТекКод = ТекСклад.Код;
        ТекИмя = СокрЛП(ТекСклад.Наименование);
        
        ТаблСклады = мStorageConnector.GetTable(tableName);

ть

Ошибка = "";

    ПодключитьТерминал();
    
    Если мОбъектТСД = Неопределено Тогда
        Возврат;
    КонецЕсли;

    Если мStorageConnector = Неопределено Тогда
        Попытка
            мStorageConnector = мДрайверТСД.CreateStorageConnector();
        Исключение
            Сообщить("Ошибка при подключении сервера Mobile SMARTS: " + ОписаниеОшибки());
            Возврат;
        КонецПопытки;        
    КонецЕсли;
    СтрокаТаблицы = Новый COMObject("Cleverence.Warehouse.Row");
    tableName = "ТранзитныеСклады";
    
    Для каждого ТекСтрока из Объект.Склады Цикл
        ТекСклад = ТекСтрока.Склад;
        Если не ЗначениеЗаполнено(ТекСклад) Тогда
            Продолжить;
        КонецЕсли;
        ТекКод = ТекСклад.Код;
        ТекИмя = СокрЛП(ТекСклад.Наименование);
        
        ТаблСклады = мStorageConnector.GetTable(tableName);

пишет ошибку:

Текущая база Mobile SMARTS не установлена

Установленный продукт:
wifi ПРОФ
Версия драйвера:
3.0.0
Типовая конфигурация драйвера?:
Нет
Операционная система:
Win 7 64
Версия и конфигурация 1С, и режим работы (Файловы или Серверный):
8.3 серверный
Типовая конфигурация 1с?:
Нет
Модель ТСД:
Cipher lab cp60

мStorageConnector = мДрайверТСД.CreateStorageConnector(); - с помощью этой строки Вы создали новый объект StorageConnector, который не подключен ни к одной базе Mobile SMARTS, поэтому когда Вы вызываете мStorageConnector.GetTable, получаете ошибку, т.к. коннектор не знает, откуда ему загружать данные. мДрайверТСД - это объект TerminalConnector, который уже подключен к базе MS? Тогда получить подключенный к базе StorageConnector можно так: мStorageConnector = мДрайверТСД.ПолучитьОбъектСоединенияСБазой(). Подключить новый StorageConnector к базе можно так:  мStorageConnector.УстановитьПодключениеСБазойСМАРТС(<Ид базы или строка соединения с базой>)

Сервис поддержки клиентов работает на платформе UserEcho