На рассмотрении

Обновление товарного справочника на ТСД (Android)

Сергей Бельфер 3 года назад в Вопросы по настройкам обновлен Алексей (Старший специалист) 3 года назад 5

Добрый день!

Установил на ТСД клиент версии Версия 2.7.х с официального сайта.

При подключении к серверу mobile smarts, на ТСД подтянулась актуальная конфигурация, но файлы Cleverence.Warehouse.ProductsBook, products.trie, products.ver, productsIndex не обновились. Когда я скопировал эти файлы на терминал непосредственно с сервера, при сканировании возникла ошибка несоответствия версий файла (trie2.0) и программы( trie2.2)

Подскажите пожалуйста, как устранить проблему с загрузкой номенклатурного справочника.

Установленный продукт:
Клиент под Android Версия 2.7.х, MobileSMARTS.apk
Версия драйвера:
2.7.1.46
Типовая конфигурация драйвера?:
Да
Операционная система:
android 5.1
Версия и конфигурация 1С, и режим работы (Файловы или Серверный):
работаю не с 1С
Типовая конфигурация 1с?:
Нет
Модель ТСД:
CARIBE PL-40L
Начат

Добрый день,

продукты на платформе 2.7 являются устаревшими и не поддерживаются (ошибки не исправляются, не дорабатываются).

Используйте версию 3.х и на ПК и на ТСД,

Вы используете продукт (батч драйвер, Магазин 15) или только платформу MobileSMARTS?

Использую только платформу MobileSMARTS. На терминалах с winCE все работает правильно с версией 2.6.7.10.


Сейчас смотрел лог ошибок на ТСД - попытка обновления отразилась так:


0; 82; 11.05.2017 10:17:48.632 ERROR
ADDITION TEXT:    WebClient::DownloadFileAsync
MESSAGE:    The remote server returned an error: (404) Not Found.
TYPE:        System.Net.WebException
SOURCE:        System
TARGETSITE:    CheckFinalStatus
[STACK TRACE]
RESPONSE:    System.Net.HttpWebResponse
STATUS:        ProtocolError
HRESULT:    -2146233079
DATA:        System.Collections.Generic.Dictionary`2[System.Object,System.Object]


0; 82; 11.05.2017 10:17:48.641 ERROR
ADDITION TEXT:    DataExchanging.LoadBooks:LoadProducts function
MESSAGE:    The remote server returned an error: (404) Not Found.
TYPE:        System.Net.WebException
SOURCE:        System
TARGETSITE:    CheckFinalStatus
[STACK TRACE]
RESPONSE:    System.Net.HttpWebResponse
STATUS:        ProtocolError
HRESULT:    -2146233079
DATA:        System.Collections.Generic.Dictionary`2[System.Object,System.Object]


На рассмотрении

Для работы с андроид ТСД нуждно использовать 3*** версию платформы http://www.cleverence.ru/files/16378/MobileSMARTS.msi. Если у вас что то доработано доработки нужно переносить.

С 2.6*** андроид работать не будет, и никогда не работал.

А можете дать ссылку на тему по обновлению версии сервера ?

Дело в том, что у меня в сервере стоит usb-токен с лицензионным ключом.
Каков механизм лицензирования для последней версии платформы ?

"А можете дать ссылку на тему по обновлению версии сервера ?" - Устанавливается начисто, 2* и 3* версии платформы между собой не совместимы.

"Дело в том, что у меня в сервере стоит usb-токен с лицензионным ключом. " - не совсем понял о чем это...

"Каков механизм лицензирования для последней версии платформы ?" - о лицензировании тут http://www.cleverence.ru/support/category:53/

Сервис поддержки клиентов работает на платформе UserEcho